JDK1.5.0+TomCat5.5.20+Eclipse3.2.1+MyEclipse5.0.1搭建JSP环境终极解决方案

Click Here To Download This Content

一、下载
1,下载JDK1.5.0
http://java.sun.com/javase/downloads/index.jsp
2,下载TomCat5.5.20
http://sourceforge.net/projects/jaxmao
3,下载Eclipse3.2.1
http://www.eclipse.org/downloads/index.php
4,下载MyEclipse5.0.1
http://www.myeclipseide.com/Downloads%2Bindex-req-viewsdownload-sid-15.html
这个需要注册会员,然后才能看到下载页面,而且不是免费版的,不过后面会告诉你怎么破解。
5,下载Eclipse中文汉化包
http://sunsite.informatik.rwth-aachen.de/eclipse/downloads/drops/L-3.0.1_Translations-200409161125/NLpack-eclipse-SDK-3.0.x-win32.zip
6,下载Tomcat插件Sysdeo Eclipse Tomcat Launcher plugin
http://www.sysdeo.com/sysdeo/content/download/657/7658/file/tomcatPluginV32beta.zip
二、安装
1,首先安装JDK,直接双击下载的文件,我的安装目录为E:/program files/Java/jdk。设置环境变量,依次点击"我的电脑(右键属性)–>高级–>环境变量–>系统变量",然后点击新建:
JAVA_HOME=e:Program FilesJavajdk;
ClassPath=.;%JAVA_HOME%libdt.jar;%JAVA_HOME%libtools.jar;(.;不能少,表示当前路径)
然后编辑Path= %JAVA_HOME%bin; (系统里已经有了path变量,只需要在path最前面加上去即可)
测试:public class Myjava{
public static void main(String args[]){
System.out.println("Hello,World.");
}
}
将上面的这段程序保存为文件名为Myjava.java的文件。
然后打开命令提示符窗口,cd到你的Myjava.java所在目录,然后键入下面的命令
javac Myjava.java
java Myjava
此时如果看到结果Hello,World.的话表示安装成功,出错则仔细检查一下你的配置情况。
2,安装TomCat,安装过程中需要指定已经安装的JDK目录,我的安装目录为E:/program files/Java/TomCat,安装好以后设置环境变量,新建:
CATALINA_HOME=e:Program FilesJavaTomcat;
CATALINA_BASE=e:Program FilesJavaTomcat;
编辑classpath,添加%CATALINA_HOME%commonlibservlet-api.jar;
测试:启动tomcat,在IE中访问http://localhost:8080, 如果看到tomcat的欢迎页面的话说明安装成功了。
3,安装Eclipse,解压下载的文件包,直接就可以用了,我的解压目录为E:/program files/Java/Eclipse.
4,安装MyEclipse,双击安装文件,然后根据提示选择Eclipse的存在目录,直接点击下一步就OK了.
5,安装TomCat插件,其实是解压,然后将目录Copy到Eclipse安装目录下的plugins目录内.
6,安装中文汉化包,将下载的压缩包解压,然后直接覆盖Eclipse目录即可.
三、配置
1,运行Eclipse,窗口–>首选项–>Tomcat,选择相应的版本,我们现在选择Version 5.x,然后指定Tomcat home为Tomcat的安装目录,其它不用处理,点击应用,确定.
2,还是在首选项里,点开MyEclipse目录树,点击Subscription,点击Enter Subscription,然后输入Subscriber:www.1cn.biz Subscriber Code: jLR8ZC-444-55-4467865481680090,点击确定破解完毕.
OK,现在JSP环境搭建好了,Eclipse也可以用了,现在你就可以进入Eclipse创建自己的项目了.

今天先写到这吧,其实以前也写了不少了,只是比较分散,这次做个总结.还有一点,Tomcat5.5.xx一定要用

JDK1.5.xx的版本及其更新才能正常运行.

Leave a Comment

Your email address will not be published.

*